GoToMyPC Toll-free number unavailable
Incident Report for GoToMyPC® System Status
Resolved
Our vendor reports that all toll-free number operation has been restored. We sincerely apologize for the inconvenience this has caused.
Posted about 2 years ago. Sep 18, 2015 - 13:15 UTC
Update
Our toll-free telecom provider has reported a major service disruption in their infrastructure, and is continuing to work to resolve the cause of this event. Support is available at the toll number listed below, and we sincerely apologize for the inconvenience this has caused.
Posted about 2 years ago. Sep 18, 2015 - 02:08 UTC
Investigating
The US toll-free number to reach GoToMyPC Customer Support (855-352-9002) is currently unavailable due to a telecom issue. We are working with the service provider to restore service - in the meantime, GoToMyPC Support can be reached at 805-617-7000 in the interim.
Posted about 2 years ago. Sep 17, 2015 - 19:12 UTC