GoToMyPC Login Page Failing to Load
Incident Report for GoToMyPC® System Status
Resolved
We have confirmed that GoToMyPC functionality has been completely restored and we are 100% operational at this time.
Posted about 2 months ago. Jul 27, 2017 - 15:42 UTC
Monitoring
Our engineers have identified the source of the issue and corrected it. The page and desktop shortcuts are now working as expected and the platform is fully operational at this time. We are continuing to monitor the situation to ensure the issue is completely resolved.
Posted about 2 months ago. Jul 27, 2017 - 15:04 UTC
Investigating
The GoToMyPC log in page is failing to load and giving an error stating that "This site can't be reached". This also appears to be affecting desktop shortcuts to host computers, though in flight sessions do not appear affected.

We are actively investigating.
Posted about 2 months ago. Jul 27, 2017 - 14:50 UTC