GoToMyPC website not loading.
Incident Report for GoToMyPC® System Status
Resolved
AT this time service has been fully restored.
Posted almost 2 years ago. Apr 03, 2015 - 23:14 UTC
Monitoring
DNS changes have been made to correct this issue. The changes are currently propagating and we are monitoring the progress.
Posted almost 2 years ago. Apr 03, 2015 - 23:03 UTC
Investigating
We are currently investigating an issue affecting the http://gotomypc.com website and causing it not to load.
Posted almost 2 years ago. Apr 03, 2015 - 22:08 UTC