GoToMyPC Webpage unavailable
Incident Report for GoToMyPC® System Status
Resolved
Investigation is complete and we can confirm we are currently 100% operational.

Thank you for your patience while this incident was investigated. We apologize for any inconvenience.
Posted almost 2 years ago. Dec 11, 2015 - 21:03 UTC
Investigating
The GoToMyPC website is currently unavailable, and produces a 404 error when accessed.

The login page can be accessed by following the URL: https://www.gotomypc.com/en_US/members/login.tmpl

We have opened a priority incident with our network operations team to diagnose and resolve this issue, and apologize for the inconvenience.
Posted almost 2 years ago. Dec 11, 2015 - 18:48 UTC