Service unavailable
Incident Report for GoToMyPC® External Status
Resolved
A local issue has been identified and resolved. All services are 100% operational. We keep monitoring the affected components closely.

We sincerely apologize to those who had been affected.
Posted 9 days ago. Dec 06, 2017 - 07:02 EST
Investigating
Very few customers may experience a service unavailable website when trying to login to the GotoMyPC Account.

A high priority ticket has been filed to investigate. We sincerely apologize to those affected.
Posted 9 days ago. Dec 06, 2017 - 06:18 EST