Potential delays in GoToMyPC email deliveries
Incident Report for GoToMyPC® System Status
Resolved
The issue causing email delays has been resolved. All new mail is processing immediately.
Posted 7 months ago. Jan 04, 2017 - 00:11 UTC
Monitoring
We have identified the issue and are working towards a resolution. At this time email delivery appears consistent. If you are still waiting on an email request, please resend the email.
Posted 7 months ago. Jan 03, 2017 - 22:01 UTC
Investigating
We are investigating delays with delivering emails including user/manager invitation emails, password reset emails, and guest invitation emails.

We apologize for any inconvenience this has caused.
Posted 7 months ago. Jan 03, 2017 - 21:52 UTC