Citrix Phone System disturbed [NO Product affected]
Incident Report for GoToMyPC® System Status
Resolved
We solved the internal Phone system issue and all contacts should be reachable again.
We apologize for the inconvenience
Posted almost 2 years ago. Feb 15, 2016 - 11:00 UTC
Investigating
Currrently our interenal phone system is disturbed. Customers may not be able to reach a contact person at this moment. No product functions are affected!
Please use our Support center help.citrix.com to find answers to your questions or create a ticket.
We apologize for the inconvenience this amy cause
Posted almost 2 years ago. Feb 15, 2016 - 09:54 UTC