GoToMyPC website unavailable
Incident Report for GoToMyPC® System Status
Resolved
Services have been restored and we are 100% operational at this time. Root cause analysis to follow. Thank you for your patience.
Posted almost 3 years ago. Nov 17, 2014 - 21:41 UTC
Investigating
Customers are reporting the following:
- Unable to access GoToMyPC from website or endpoint.

We sincerely apologize for the disruption in service to you and your customers. This is top priority and we are working towards a resolution as quickly as possible.

We sincerely apologize for the disruption in service to you and your customers. This is top priority and we are working towards a resolution as quickly as possible
Posted almost 3 years ago. Nov 17, 2014 - 21:09 UTC