GoToMyPC Password Issues
Incident Report for GoToMyPC® System Status
Resolved
This incident has been resolved.
Posted 9 months ago. Jun 30, 2016 - 21:24 UTC
Monitoring
Citrix takes the safety and security of its customers very seriously, and is aware of the password attack on GoToMyPC. Once Citrix determined the nature of the attack, it took immediate action to protect customers. Citrix can confirm the recent incident was a password re-use attack, where attackers used usernames and passwords leaked from other websites to access the accounts of GoToMyPC users.

At this time, the response includes a mandatory password reset for all GoToMyPC users. Citrix encourages customers to visit the GoToMyPC status page to learn about enabling two-step verification, and to use strong passwords in order to keep accounts as safe as possible. Further, there is no indication of compromise to any other Citrix product line.

Frequently Asked Questions:

Q: What happened?
A: GoToMYPC (G2P) came under a password attack. Once we determined the nature of the attack, we took immediate action to protect our customers. Citrix can confirm the recent incident was a password re-use attack, where attackers used usernames and passwords leaked from other websites to access the accounts of GoToMyPC users.

Q: Was GoToMyPC the only product impacted by the attack?
A: Yes, GoToMyPC was the only product line effected. There is no indication any other product was impacted.

Q: What did Citrix do?
A: In order to protect our customers, we have set a mandatory password reset for all GoToMyPC users. We encourage our members to enable two-step verification, and to use strong passwords in order to keep their accounts as safe as possible.

Q: What should I do if I am a GoToMyPC customer?
A: To protect you, the GoToMYPC security team reset all customer passwords.

Next Steps: .
You will be required to reset your GoToMYPC password before you can login again.
To reset your password please use your regular GoToMYPC login link.
Recommendations for a strong password
• Don’t use a word from the dictionary
• Select strong passwords that can't easily be guessed with 8 or more characters
• Make it Complex – Randomly add capital letters, punctuation or symbols
• Substitute numbers for letters that look similar (for example, substitute “0” for “o” or “3” for “E”)
• Don't use the same password in more than one place
2-step Verification option
We recommend everyone use the 2-step Verification option for GoToMyPC accounts. http://support.citrixonline.com/en_US/gotomypc/help_files/GTC070021?title=2-Step+Verification

Q: Was any personal information compromised?
A: Our initial assessment indicates that no sensitive customer data (such as credit card information) was exposed. We are continuing an in-depth forensic investigation and will share the results of this investigation as soon as feasible.

Q: Where can we go find more information about the event?
A: http://status.gotomypc.com
Posted 9 months ago. Jun 20, 2016 - 22:46 UTC
Update
Update - We sincerely apologize for the inconvenience and frustration this issue may be causing.

IMPORTANT SECURITY MESSAGE FROM THE GoToMYPC TEAM

Dear Valued Customer,

Unfortunately, the GoToMYPC service has been targeted by a very sophisticated password attack. To protect you, the security team recommended that we reset all customer passwords immediately.
Effective immediately, you will be required to reset your GoToMYPC password before you can login again.
To reset your password please use your regular GoToMYPC login link.
Recommendations for a strong password
• Don’t use a word from the dictionary
• Select strong passwords that can't easily be guessed with 8 or more characters
• Make it Complex – Randomly add capital letters, punctuation or symbols
• Substitute numbers for letters that look similar (for example, substitute “0” for “o” or “3” for “E”.

2-step Verification option
We encourage you to learn more about using the 2-step Verification option for GoToMyPC accounts.
The GoToMYPC Team is committed to protecting the security of our customers and our services. We apologize for any inconvenience this may have caused you.
Questions? Visit our Support Center at: http://help.citrix.com/gotomypc
Posted 9 months ago. Jun 19, 2016 - 03:26 UTC
Update
We apologize for the frustration this issue is causing.

- Please reset your password through the “Forgot Password” link located under the GoToMyPC account login https://www.gotomypc.com/en_US/members/forgotPassword.tmpl
- If you do not receive an email within a few minutes, please check your Spam and Trash folders. The email will be coming from gotocustomercare@care.gotomypc.com
- If you have set up an Alternate email address in your account settings, the Forgot Password email will be sent there also. Directions to adding an Alternate email address to your account after your login can be found here: http://support.citrixonline.com/en_US/gotomypc/help_files/GTC140006?title=Forgot+Your+Account+Password
- When resetting your password we highly recommend using a new password and not the same one the account was set to previously, if possible. In addition we would like to remind all users that GoToMyPC offers 2-step Verification, an additional preference which can further enhance security of your account. For more information on 2-Step Verification please see: https://support.citrixonline.com/en_US/GoToMyPC/help_files/GTC070021?title=2-Step+Verification

If you do not have access to your account email because it is no longer valid, and do not have an Alternate email address in your account settings, we will need to verify your details over the telephone in order to assist you. Please visit this page http://help.citrix.com/contactus-c, select GoToMyPC and click on Create a Ticket. Provide the email address associated with your account and your telephone number so that one of our Reps can call you and assist further.
Posted 9 months ago. Jun 18, 2016 - 21:22 UTC
Investigating
We have experienced an issue which requires you to reset your password if you are having trouble logging into your account.   Please reset your password through the “Forgot Password” link if you are having trouble logging into your account.

https://www.gotomypc.com/en_US/members/forgotPassword.tmpl
Posted 9 months ago. Jun 18, 2016 - 14:13 UTC